社会人はリラックスしたい

社会人はリラックスしたい

アラサーリーマンです。漫画の感想を主に、メンズファッション初心者向けの服レビュー、乗馬未経験者・初心者向けの記事を書いていきます。

python エラー対処の覚書 

自分用のメモです。

 

あるオンラインテキストでpandasを使った処理をしたら下記のようなエラーがでた。

調べた感じ、pandasのバージョンが古いことが原因っぽい。

No module named 'pandas.core.internals.managers'; 'pandas.core.internals' is not a package

 

 

PCに入っているpandasのバージョンを調べてみる(下)と0.23で、新しいものは1.0も出ているらしい。

いきなり1.0までupdateして不具合が出るのも嫌なので0.25をupdateすることに。

print(pd.__version__)
pd.show_versions() 

 

cmdでコマンドプロンプトを呼び出して>"pip install pandas==0.25"と打ち込んで少し待ったらインストール完了。古い0.23はアンインストールされたっぽい。

jupyter notebookが機能しなくなったので若干あせったが、再起動したら特に問題なく動くようになり、上のエラーもでなくなった。

 

めでたしめでたし